Full Text Search Delays
Incident Report for FLG
Resolved
Thanks for your patience, we've fixed the problem.
Posted Jul 01, 2014 - 17:12 BST
Identified
There's a delay in updating our full text search index currently. That means searching by keyword for very recent leads may not show up leads you expect to see. We're working on this now.
Posted Jul 01, 2014 - 16:58 BST