554 Rejection on Incoming Email
Incident Report for FLG
Resolved
Our service provider has told us the issue is resolved. If the situation changes we'll update you here. Our apologies if this impacted you.
Posted Jun 16, 2014 - 15:36 BST
Investigating
Our email service provider have made us aware of an issue which is affecting incoming email: "We have identified an issue where some messages are rejected with 554 "cannot accept your message". We will post more information shortly. Thanks for your patience!".
Posted Jun 16, 2014 - 15:05 BST