Delays opening up emails
Incident Report for FLG
Resolved
All is still well so we're closing this incident now. We'll make sure it doesn't reoccur.
Posted Dec 04, 2014 - 13:20 GMT
Monitoring
This was again related to a misbehaving backup operation. Access to emails is now back to normal again. We'll be implementing a permanent fix today. Sorry for keeping you waiting this morning.
Posted Dec 04, 2014 - 12:16 GMT
Identified
Unfortunately, we're again seeing a delay when opening up (or replying to) emails. We're investigating now.
Posted Dec 04, 2014 - 11:45 GMT