Access problems
Incident Report for FLG
Resolved
We have found the error and resolved the issue. We're sorry we went away for a few minutes there.
Posted May 02, 2014 - 14:33 BST
Investigating
We are aware of problems with the service right now. Investigating..
Posted May 02, 2014 - 14:30 BST