Some users reporting slow access
Incident Report for FLG
Resolved
This incident has been resolved.
Posted Jun 23, 2015 - 19:23 BST
Monitoring
We believe performance has returned to normal levels. The root cause is known and is being dealt with. We're monitoring performance now.
Posted Jun 23, 2015 - 16:17 BST
Investigating
We are currently investigating this issue.
Posted Jun 23, 2015 - 16:06 BST