Accessing the Service is Slow
Incident Report for FLG
Resolved
Sorry about the slow patch, the issue has been resolved.
Posted Dec 16, 2016 - 12:27 GMT
Investigating
We are currently investigating this issue.
Posted Dec 16, 2016 - 12:20 GMT