Service Disruption
Incident Report for FLG
Resolved
This incident has been resolved.
Posted Apr 08, 2014 - 15:18 BST
Identified
We believe the root cause of this is fixed. You *may* need to clear out cookies to sign in. If you're still having problems, please get in touch. Sorry for interrupting your busy day!
Posted Apr 08, 2014 - 15:18 BST
Investigating
We're aware that users are having trouble signing in at the moment and seeing strange behaviour. Investigating now..
Posted Apr 08, 2014 - 15:07 BST