Service Unavailable
Incident Report for FLG
Resolved
This incident has been resolved.
Posted Oct 20, 2015 - 22:46 BST
Monitoring
Although service was interrupted briefly, we are now available again. We're monitoring the situation.
Posted Oct 20, 2015 - 22:37 BST
Investigating
We are currently investigating this issue.
Posted Oct 20, 2015 - 22:35 BST