Inbound Lead Processing
Incident Report for FLG
Resolved
Sorry for the delay this morning. As this is now resolved we're closing this incident.
Posted May 19, 2014 - 11:19 BST
Update
To clarify, inbound leads are no longer delayed.
Posted May 19, 2014 - 10:39 BST
Monitoring
We've fixed the root cause of the issue and will be monitoring the situation for the time being.
Posted May 19, 2014 - 10:34 BST
Investigating
The processing of inbound leads is approximately 10 minutes behind. We're looking into this right now.
Posted May 19, 2014 - 10:27 BST