Outbound Delivery Delays
Incident Report for FLG
Resolved
The issue has been fixed. There was an issue with one of our email platform's sending turrets that caused it to be unable to connect to any MX servers. All messages that temporarily failed will be retried and processed as normal. Sorry for the hassle this caused you this afternoon.
Posted Mar 25, 2015 - 17:10 GMT
Monitoring
The MX errors have largely cleared up now and we believe delivery is back to normal. Some outbound email is still in the pipeline for retry. We'll keep a close eye on things for now.
Posted Mar 25, 2015 - 16:52 GMT
Update
There does seem to be a higher than normal rate of MX lookup errors (DNS related, where our servers try and find out the mail server address that needs to be contacted). This isn't affecting all mail, some of it is being delivered. The ones failing on the MX lookup are being scheduled for retry. We'll continue getting to the root of the problem and will update you again shortly.
Posted Mar 25, 2015 - 16:26 GMT
Investigating
Some customers have reported delays in sending email. We're looking into that now. We'll update again in the next half hour or sooner.
Posted Mar 25, 2015 - 16:10 GMT