Workflows with actions that happen when a lead is created
Incident Report for FLG
Resolved
We're sorry about this problem this afternoon - it's now fixed.
Posted Dec 01, 2014 - 16:54 GMT
Identified
Workflow actions that should happen when the lead is created are currently not being run. They're sitting at status 'Due Now'. We're fixing that right now.
Posted Dec 01, 2014 - 16:30 GMT