Some connections timing out
Incident Report for FLG
Resolved
We're closing this issue as things are looking good now. Sorry if this caused you a problem using the service earlier.
Posted Jan 18, 2015 - 21:30 GMT
Monitoring
The problems with Level3 in Manchester do appear to be the cause of this incident. We're no longer affected by it and we're monitoring the situation.
Posted Jan 18, 2015 - 19:56 GMT
Update
This appears to be related to this incident with our network provider: "Level3 (one of our two IP transit providers) have experienced a combination of faults in Manchester, that led to the routers there being isolated from the rest of their network."

We're still working to confirm this is the cause and mitigate.
Posted Jan 18, 2015 - 19:46 GMT
Investigating
It seems that some operations in the UI are timing out. We're figuring this out now.
Posted Jan 18, 2015 - 19:43 GMT