Service Access Disrupted
Incident Report for FLG
Resolved
We're sorry if this affected you. Service was unavailable for around 2 minutes. We've identified the cause and we're now marking this incident as resolved.
Posted Jul 24, 2015 - 15:32 BST
Identified
A few moments ago access to FLG was briefly interrupted.
Posted Jul 24, 2015 - 15:24 BST